The two attributes roadName and roadNumber are part of the LinearElement class. Their definition is specific for Linears, which makes it impossible to reuse these attributes elsewhere. Newertheless, these two attributes are valueable in a more general context.
* change both definitions to more general terms
* consider to move these attributes into a higher place of hierarchy, for example into the NetworkLocation class or into the SupplementaryPositionalDescription class (note that a Point for example is also usually located on a road).
* consider to rename roadNumber into roadIdentifier (but as a MultilingualString) (to put in identifier or number)
Further note, that the ParkingPublications come with the following two attributes in the Road class: nameOfRoad, roadIdentifier. These elements should be harmonized when considering the issue above.
I agree, we have an extension for this is Sweden on Location
Implemented resolution documented by Loic (definition changes)