Bad name for top level package

Submitted by Josef Kaltwasser on Friday, 21 October, 2011 - 17:00
Issue ID
61
Component
Methodology
Category
Bug report
Priority
Normal
Assigned
Status
Fixed
Source
Website
Description

GB
8.2a
te

The name "D2LogicalModel" breaks a rule of good
practice for modelling: that the name of a class should
describe an instance of the class, and in general the
model should be named to represent the thing being
modelled. This model is the D2LogicalModel, it does not
represent the D2LogicalModel. There may be a counterview
that the data represents an abstract model of traffic
and travel environment and so the subject matter is itself
still a model; however this view overloads the word
"model" confusingly and is unconventional.

We suggest "Datex", "Datex2" or "D2" for the top
level package name and for the top level class
name perhaps append the word "Communication"
to the chosen name for the top package.

{"changeLogs":[{"date":1528112548485,"statusOLD":"- None -","status":"Fixed","assignedOLD":"","assigned":"Josef Kaltwasser (18)","priorityOLD":"- None -","priority":"Normal","categoryOLD":"- Select a value -","category":"Bug report","componentOLD":"- Select a value -","component":"Methodology"},{"date":1537269965183}]}

Posted by iancornwell on November 14, 2021 Permalink

Agreed in email discussion between JJ, JK, BdV and others to use the name "D2Payload". Changed in model revision #708, and since the package is now explicitly about payload, there were corresponding changes to definition and a tagged value (type).